Re: [PATCH] tree wide: Use kvfree() than conditional kfree()/vfree()
From: Tetsuo Handa
Date: Sun Nov 08 2015 - 00:05:14 EST
Andy Shevchenko wrote:
> Like Joe noticed you have left few places like
> void my_func_kvfree(arg)
> {
> kvfree(arg);
> }
>
> Might make sense to remove them completely, especially in case when
> you have changed the callers.
I think we should stop at
#define my_func_kvfree(arg) kvfree(arg)
in case someone want to add some code in future.
Also, we might want to add a helper that does vmalloc() when
kmalloc() failed because locations that do
ptr = kmalloc(size, GFP_NOFS);
if (!ptr)
ptr = vmalloc(size); /* Wrong because GFP_KERNEL is used implicitly */
are found.
> One more thought. Might be good to provide a coccinelle script for
> such places? Julia?
Welcome. I'm sure I'm missing some locations.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/