Re: [RFC PATCH v3 1/4] drm: Introduce generic probe function for component based masters.

From: Liviu Dudau
Date: Mon Nov 09 2015 - 08:28:10 EST

On Mon, Nov 09, 2015 at 12:03:35PM +0000, Russell King - ARM Linux wrote:
> On Mon, Nov 09, 2015 at 11:57:27AM +0000, Liviu Dudau wrote:
> > Meanwhile, what is your suggestion regarding the patchset. I've seen David has
> > sent Linus a pull request for 4.4-rc1 that includes it. Should we send a
> > revert for rockchip commit and then patch later the function?
> It definitely needs to be fixed, and I'd suggest its early enough in the
> -rc cycle (which hasn't begun yet) to simply fix drm_of_component_probe()
> to take two compare functions.

I still don't have a Rockchip board to test the patch, so I need to find out
someone willing to test them. Mark?

> I'd also suggest at this point another change: please rename it to
> drm_of_kms_component_probe() since this is only a generic case for KMS
> drivers. GPU DRM drivers need something different.

OK, will do.

> --
> FTTC broadband for 0.8mile line: currently at 9.6Mbps down 400kbps up
> according to

| I would like to |
| fix the world, |
| but they're not |
| giving me the |
\ source code! /
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at