no sound on Meegopad T02 with 4.3 kernel

From: Jamin Collins
Date: Thu Nov 12 2015 - 19:32:33 EST

I'm having trouble getting sound working on a Meegopad T02[1]. I'm
running Arch with a 4.3 kernel[2] with patches[3] for wifi stability.

So far, the drivers appear to load, but produce the following dmesg output:

> [ 5.579629] baytrail-pcm-audio baytrail-pcm-audio: ipc: error DSP boot timeout
> [ 5.579841] byt-rt5640 byt-rt5640: ASoC: CPU DAI baytrail-pcm-audio not registered

No devices are listed in the output from 'aplay -l' (presumably due to
the above):

> $ aplay -l
> aplay: device_list:268: no soundcards found...

I've tried alternative firmware[4], but still get output like the above.

The system is a Baytrail compute stick (similar to Intel's Compute
Stick) and supports both HDMI audio and analog jack.

There appears to be a patch from Intel[5], but it's monolithic and
targetted toward a much older kernel. It's also a bit unclear if any
of the patches were ever upstreamed.

Am I doing something obviously wrong here? If not, are there any
patches I can try to get this thing working?

[1] -
[2] -
[3] -
[4] -
[5] -
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at