Re: [PATCH 7/7] mm/mmzone: refactor memmap_valid_within

From: Michal Hocko
Date: Mon Nov 16 2015 - 07:45:09 EST


On Mon 16-11-15 14:51:26, Yaowei Bai wrote:
[...]
> @@ -72,16 +72,10 @@ struct zoneref *next_zones_zonelist(struct zoneref *z,
> }
>
> #ifdef CONFIG_ARCH_HAS_HOLES_MEMORYMODEL
> -int memmap_valid_within(unsigned long pfn,
> +bool memmap_valid_within(unsigned long pfn,
> struct page *page, struct zone *zone)
> {
> - if (page_to_pfn(page) != pfn)
> - return 0;
> -
> - if (page_zone(page) != zone)
> - return 0;
> -
> - return 1;
> + return page_to_pfn(page) == pfn && page_zone(page) == zone;

I do not think this is easier to read. Quite contrary

> }
> #endif /* CONFIG_ARCH_HAS_HOLES_MEMORYMODEL */
>
> --
> 1.9.1
>
>

--
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/