[PATCH 0/3 v8] livepatch: disambiguate symbols with the same name

From: Chris J Arges
Date: Fri Nov 20 2015 - 12:25:36 EST

Currently, patching objects with duplicate symbol names fail because the
creation of the sysfs function directory collides with the previous
attempt. Appending old_addr to the function name is problematic as it
reveals the address of the function being patch to a normal user. Using
the symbol's occurrence in kallsyms to postfix the function name in the
sysfs directory solves the issue of having consistent unique names and
ensuring that the address is not exposed to a normal user.

In addition, using the symbol position as the user's method to disambiguate
symbols instead of addr allows for disambiguating symbols in modules as
well for both function addresses and for relocs. This also simplifies much
of the code. Special handling for kASLR is no longer needed and can be
removed. The klp_find_verify_func_addr function can be replaced by
klp_find_object_symbol, and klp_verify_vmlinux_symbol and its callback can
be removed completely.

The following set of patches use symbol positioning instead of old
addresses to disambiguate symbols that have the same name in a given
object. This is necessary in order to be able to patch symbols with the
same name within the same object. This requires modifications to the
klp_func and klp_reloc structures to add an additional element. In addition
the scheme used for the func directory in sysfs is modified to append the
symbols occurrence in kallsyms.

- explain motivation and necessity in initial patch
- don't support sympos for external relocations

- make count/pos checking in klp_find_callback more readable
- fix klp_write_object_relocations sympos/external checking

- move sympos arg before addr in klp_find_object_symbol
- make comments more accurate, remove unnecessary whitespace
- improve cover letter

- remove val from klp_reloc struct
- klp_write_object_relocations doesn't use sympos with external relocs
- add Petr Mladek's patch to simplify relocated external symbol code
- add optimization in klp_find_callback in unique case
- remove klp_find_verify_func_addr
- amend/remove commit messages/comments to be more precise

Chris J Arges (3):
livepatch: add old_sympos as disambiguator field to klp_func
livepatch: add sympos as disambiguator field to klp_reloc
livepatch: function,sympos scheme in livepatch sysfs directory

Documentation/ABI/testing/sysfs-kernel-livepatch | 6 +-
include/linux/livepatch.h | 24 ++--
kernel/livepatch/core.c | 157 ++++++++---------------
3 files changed, 73 insertions(+), 114 deletions(-)


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/