[PATCH 2/4] livepatch: use list_is_first()

From: Geliang Tang
Date: Thu Dec 10 2015 - 09:19:32 EST


For better readability, use list_is_first() instead of open-coded.

Signed-off-by: Geliang Tang <geliangtang@xxxxxxx>
---
kernel/livepatch/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/kernel/livepatch/core.c b/kernel/livepatch/core.c
index bc2c85c..be64106 100644
--- a/kernel/livepatch/core.c
+++ b/kernel/livepatch/core.c
@@ -479,7 +479,7 @@ static int __klp_enable_patch(struct klp_patch *patch)
return -EINVAL;

/* enforce stacking: only the first disabled patch can be enabled */
- if (patch->list.prev != &klp_patches &&
+ if (!list_is_first(&patch->list, &klp_patches) &&
list_prev_entry(patch, list)->state == KLP_DISABLED)
return -EBUSY;

--
2.5.0


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/