Well, "utilization" and "bandwidth" are often used to indicate the sameSmall nit: why "average" utilization? I think a better name would be
"runqueue utilization"
or "local utilization", or something similar... If I understand correctly
(sorry if I
missed something), this is not an average, but the sum of the
utilisations
of the tasks
on this runqueue... No?
I have used "average" because it doesn't reflect the active/actual
utilization of the run-queue but the forecasted average bandwidth of
the CPU that will be used by deadline task.
Well, this is just nitpicking, so feel free to ignore (I just mentioned
this point because I was initially confused by the "average" name). But I
think this is "maximum", or "worst-case", not "average", because (as far
as I can understand) this field indicates that SCHED_DEADLINE tasks will
not be able to consume more than this fraction of CPU (if they try to
consume more, the scheduler throttles them).
I'm open to change the name if another one makes more sense
In real-time literature this is often called simply "utilization" (or
"worst-case
utilization" by someone): when a task can have a variable execution time,
its
utilization is defined as WCET (maximum execution time) / period.
ok. Let follow real-time literature wording and remove "average" to
keep only utilization.
so the variable will be named:
s64 util_bw;