Re: [PATCH 2/7] edac: i5100_edac: use to_delayed_work

From: Borislav Petkov
Date: Fri Jan 01 2016 - 12:35:47 EST


On Fri, Jan 01, 2016 at 10:59:07PM +0800, Geliang Tang wrote:
> Use to_delayed_work() instead of open-coding it.
>
> Signed-off-by: Geliang Tang <geliangtang@xxxxxxx>
> ---
> drivers/edac/i5100_edac.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/edac/i5100_edac.c b/drivers/edac/i5100_edac.c
> index 4091777..c655162 100644
> --- a/drivers/edac/i5100_edac.c
> +++ b/drivers/edac/i5100_edac.c
> @@ -575,9 +575,7 @@ static void i5100_check_error(struct mem_ctl_info *mci)
>
> static void i5100_refresh_scrubbing(struct work_struct *work)
> {
> - struct delayed_work *i5100_scrubbing = container_of(work,
> - struct delayed_work,
> - work);
> + struct delayed_work *i5100_scrubbing = to_delayed_work(work);
> struct i5100_priv *priv = container_of(i5100_scrubbing,
> struct i5100_priv,
> i5100_scrubbing);
> --

Applied, thanks.

--
Regards/Gruss,
Boris.

ECO tip #101: Trim your mails when you reply.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/