Re: [PATCH 1/2] regulator: core: Use a bitfield for continuous_voltage_range
From: Joe Perches
Date: Fri Jan 22 2016 - 14:15:43 EST
On Thu, 2016-01-21 at 20:24 +0000, Mark Brown wrote:
> Using a bitfield enables the compiler to lay out the structure more
> efficiently when we have other boolean flags since multiple values can
> be included in a single byte.
>
> Signed-off-by: Mark Brown <broonie@xxxxxxxxxx>
> ---
> include/linux/regulator/driver.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/regulator/driver.h b/include/linux/regulator/driver.h
> index 16ac9e108806..3ac0f306f033 100644
> --- a/include/linux/regulator/driver.h
> +++ b/include/linux/regulator/driver.h
> @@ -281,7 +281,7 @@ struct regulator_desc {
> const struct regulator_desc *,
> struct regulator_config *);
> int id;
> - bool continuous_voltage_range;
> + unsigned int continuous_voltage_range:1;
Is this really valuable?
There are already padding bytes that are unused
and adding a couple more bools would be space
cost-free and more readable.
I believe that read/write of bytes is also more
efficient on some architectures than bit field
read/modify/write uses.
> unsigned n_voltages;
> const struct regulator_ops *ops;
> int irq;