Re: [PATCH v5] x86/setup: get ramdisk parameters only once
From: Ingo Molnar
Date: Wed Feb 17 2016 - 04:26:28 EST
* Alexander Kuleshov <kuleshovmail@xxxxxxxxx> wrote:
> - early_reserve_initrd();
> + if (!boot_params.hdr.type_of_loader || !ramdisk_image.start_addr || !ramdisk_image.size)
> + ramdisk_image.reserve_ramdisk = false; /* No initrd provided by bootloader */
> + else
> + memblock_reserve(ramdisk_image.start_addr, ramdisk_image.size);
... and _now_ it's clear that it makes sense to keep early_reserve_initrd(), move
that new chunk of code to it and pass in the ramdisk structure.
Also, please rename the too long 'ramdisk_image' local variable to something
shorter: 'rd' is commonly used - but the original 'ramdisk' name was fine too.
Thanks,
Ingo