Re: [PATCH 0/5] drivers/mtd: make several functions return bool
From: Yaowei Bai
Date: Fri Mar 25 2016 - 02:32:29 EST
On Fri, Mar 25, 2016 at 10:54:51AM +0800, Dongsheng Yang wrote:
> ccing: Brian and Richard
> Hi Yao,
> Is that really necessary? I am not sure how much benefit we can
> achieve from this change.
> Could you explain more?
Yes, according to these functions' name, a boolean return value is more
suitable and matchable.
Also personally think this change maybe benfit function's return value
storage in the stack when called on certain architectures.
> On 03/25/2016 10:41 AM, Yaowei Bai wrote:
> >This series only make several funcitons return bool to improve
> >readability, no other funcitonal changes.
> >Yaowei Bai (5):
> > drivers/mtd: mtd_is_partition can be boolean
> > drivers/mtd: cfi_interleave_supported can be boolean
> > drivers/mtd: map_bankwidth_supported can be boolean
> > drivers/mtd: mtd_nand_has_bch can be boolean
> > drivers/mtd/nand: nand_opcode_8bits can be boolean
> > drivers/mtd/mtdpart.c | 6 +++---
> > include/linux/mtd/cfi.h | 6 +++---
> > include/linux/mtd/map.h | 6 +++---
> > include/linux/mtd/nand.h | 6 +++---
> > include/linux/mtd/nand_bch.h | 4 ++--
> > include/linux/mtd/partitions.h | 2 +-
> > 6 files changed, 15 insertions(+), 15 deletions(-)