Re: [PATCH 2/2] mm: rename _count, field of the struct page, to _refcount

From: Joonsoo Kim
Date: Mon Mar 28 2016 - 02:05:31 EST

2016-03-28 14:59 GMT+09:00 <js1304@xxxxxxxxx>:
> From: Joonsoo Kim <>
> Many developer already know that field for reference count of
> the struct page is _count and atomic type. They would try to handle it
> directly and this could break the purpose of page reference count
> tracepoint. To prevent direct _count modification, this patch rename it
> to _refcount and add warning message on the code. After that, developer
> who need to handle reference count will find that field should not be
> accessed directly.
> Signed-off-by: Joonsoo Kim <>

Oops. This patch needs more change. Please ignore this patchset.
I will resend it soon.