Re: [PATCH 15/15] parallel lookups: actual switch to rwsem

From: Al Viro
Date: Fri Apr 15 2016 - 23:31:26 EST


On Fri, Apr 15, 2016 at 09:02:06PM -0600, Andreas Dilger wrote:

> Wouldn't it make sense to have helpers like "inode_read_lock(inode)" or similar,
> so that it is consistent with other parts of the code and easier to find?
> It's a bit strange to have the filesystems use "inode_lock()" and some places
> here use "inode_lock_nested()", but other places use up_read() and down_read()
> directly on &inode->i_rwsem. That would also simplify delegating the directory
> locking to the filesystems in the future.

FWIW, my preference would be inode_lock_shared(), but that's bikeshedding;
seeing that we have very few callers at the moment *and* there's the missing
down_write_killable() stuff... This patch will obviously be reworked and
it's small enough to be understandable, open-coding or not.