Re: [tip:x86/asm] x86/entry: Rename is_{ia32,x32}_task() to in_{ia32,x32}_syscall()

From: H. Peter Anvin
Date: Tue Apr 19 2016 - 13:02:12 EST

On April 19, 2016 4:35:01 AM PDT, Borislav Petkov <bp@xxxxxxxxx> wrote:
>On Tue, Apr 19, 2016 at 01:15:30PM +0200, Ingo Molnar wrote:
>> So I'd suggest the following renames to harmonize these concepts:
>> this lines up nicely with: CONFIG_X86_X32_ABI
>Except that the only difference now is the "X" in the strings. So one
>would need more coffee when staring at those. :)
>> - is_ia32_syscall() -> is_x86_32_syscall()
>> - is_x32_syscall() -> is_x86_x32_syscall()
>> - is_compat_syscall() remains as-is.
>> ... thoughts?
>Still, getting those names streamlined and logical is a step in the
>right direction IMO.

Let's use the i386 name instead of x86-32; that's what we use elsewhere in the kernel and is much easier to tell apart. Also, less likely to be caught up in "is this i386 only or *any* 32-bit call, including x32"?
Sent from my Android device with K-9 Mail. Please excuse brevity and formatting.