Re: [PATCHv2 2/5] arm64/efi: move to generic {__,}efi_call_virt

From: Will Deacon
Date: Thu Apr 21 2016 - 12:48:49 EST


On Thu, Apr 21, 2016 at 12:35:26PM +0100, Mark Rutland wrote:
> Now there's a common template for {__,}efi_call_virt, remove the
> duplicate logic from the arm64 efi code.
>
> Signed-off-by: Mark Rutland <mark.rutland@xxxxxxx>
> Cc: Ard Biesheuvel <ard.biesheuvel@xxxxxxxxxx>
> Cc: Catalin Marinas <catalin.marinas@xxxxxxx>
> Cc: Leif Lindholm <leif.lindholm@xxxxxxxxxx>
> Cc: Matt Fleming <matt@xxxxxxxxxxxxxxxxxxx>
> Cc: Will Deacon <will.deacon@xxxxxxx>
> Cc: linux-arm-kernel@xxxxxxxxxxxxxxxxxxx
> Cc: linux-efi@xxxxxxxxxxxxxxx
> Cc: linux-kernel@xxxxxxxxxxxxxxx
> ---
> arch/arm64/include/asm/efi.h | 21 +++++++--------------
> 1 file changed, 7 insertions(+), 14 deletions(-)
>
> diff --git a/arch/arm64/include/asm/efi.h b/arch/arm64/include/asm/efi.h
> index 8e88a69..f4f71224 100644
> --- a/arch/arm64/include/asm/efi.h
> +++ b/arch/arm64/include/asm/efi.h
> @@ -14,28 +14,21 @@ extern void efi_init(void);
>
> int efi_create_mapping(struct mm_struct *mm, efi_memory_desc_t *md);
>
> -#define efi_call_virt(f, ...) \
> +#define arch_efi_call_virt_setup() \
> ({ \
> - efi_##f##_t *__f; \
> - efi_status_t __s; \
> - \
> kernel_neon_begin(); \
> efi_virtmap_load(); \
> - __f = efi.systab->runtime->f; \
> - __s = __f(__VA_ARGS__); \
> - efi_virtmap_unload(); \
> - kernel_neon_end(); \
> - __s; \
> })
>
> -#define __efi_call_virt(f, ...) \
> +#define arch_efi_call_virt(f, args...) \
> ({ \
> efi_##f##_t *__f; \
> - \
> - kernel_neon_begin(); \
> - efi_virtmap_load(); \
> __f = efi.systab->runtime->f; \
> - __f(__VA_ARGS__); \
> + __f(args); \

Any reason to change this to a named argument? This patch is hard enough
to review as it is, given the way the diff has been generated!

Either way:

Acked-by: Will Deacon <will.deacon@xxxxxxx>

Will