Re: linux-next: manual merge of the vfs tree with the overlayfs tree

From: Al Viro
Date: Sun May 01 2016 - 21:24:16 EST

On Mon, May 02, 2016 at 02:08:39AM +0100, Al Viro wrote:

> Should use lookup_one_len_unlocked(), actually. lookup_hash() is
> a microoptimization, losing a lot more on excessive i_mutex contention.
> Either variant works, though.

PS: if anybody has a better name for lookup_one_len_unlocked(), I'll gladly
rename it; the thing hadn't been in the kernel for too long and the name is
somewhat confusing. It's an equivalent of
except that it avoids taking the lock when it's not needed.