On Tue, May 17, 2016 at 12:46:07PM -0700, Paul E. McKenney wrote:
Actually, if you show a case where this makes a visible system-wideAlternatively, could we try and talk to our GCC friends to make sure GCC
difference, you could create a set of primitives for #1 below. Have
a compiler version check, and if it is an old compiler, map them to
READ_ONCE() and WRITE_ONCE(), otherwise as follows, though preferably
with better names:
#define READ_NOTEAR(x) __atomic_load_n(&(x), __ATOMIC_RELAXED)
#define WRITE_NOTEAR(x, v) __atomic_store_n(&(x), (v), __ATOMIC_RELAXED)
The ambiguity between "no tear" and "not ear" should help motivate a
better choice of name.
doesn't tear loads/stores irrespective of what the C language spec
allows?