Re: [PATCH v2 0/6] x86: Rewrite switch_to()

From: Brian Gerst
Date: Sun Jun 19 2016 - 18:06:10 EST


On Sat, Jun 18, 2016 at 4:56 PM, Brian Gerst <brgerst@xxxxxxxxx> wrote:
> This patch set simplifies the switch_to() code, by moving the stack switch
> code out of line into an asm stub before calling __switch_to(). This ends
> up being more readable, and using the C calling convention instead of
> clobbering all registers improves code generation. It also allows newly
> forked processes to construct a special stack frame to seamlessly flow
> to ret_from_fork, instead of using a test and branch, or an unbalanced
> call/ret.
>
> Changes from v1:
> - Added struct inactive_task_frame
> - Added comments about kernel threads returning to userspace
> - Cleaned up some incorrect uses of thread.sp

I forgot to also add:
- Rearranged inactive stack frame so that BP (frame pointer) is in the
natural position right below the return address. This should take
care of unwinding issues Josh raised.

--
Brian Gerst