On Sunday, July 10, 2016 3:27:22 PM CEST Wan Zongshun wrote:
+
+#if !defined(CONFIG_SOC_NUC900)
#define NR_IRQS (IRQ_ADC+1)
+#else
+#define NR_IRQS 62
+#endif
The Kconfig symbols are a bit confusing here: CONFIG_SOC_NUC900
controls the compilation of the soc_device driver, but I guess
what you actually mean here is CONFIG_SOC_NUC970, which is the
support for the actual chip.
Maybe rename the former to something less confusing and change
this to CONFIG_SOC_NUC970?
Ideally, this should just go away once we use SPARSE_IRQ.
Arnd
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@xxxxxxxxxxxxxxxxxxx
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel