RE: [PATCH 19/32] sched.h: Add rg_list and rdtgroup in task_struct
From: Yu, Fenghua
Date: Wed Jul 13 2016 - 13:50:53 EST
> From: Thomas Gleixner [mailto:tglx@xxxxxxxxxxxxx]
> Sent: Wednesday, July 13, 2016 5:56 AM
> On Tue, 12 Jul 2016, Fenghua Yu wrote:
> > From: Fenghua Yu <fenghua.yu@xxxxxxxxx>
> > rg_list is linked list to connect to other tasks in a rdtgroup.
> Can you please prefix that member proper, e.g. rdt_group_list
There is another similar name in task_struct, which is cg_list for cgroup list.
I just follow that name to have a rg_list for rdtgroup list.
If you think rdt_group_list is a better name, I sure will change rg_list
> > The point of rdtgroup allows the task to access its own rdtgroup directly.
> 'pointer' perhaps? Also please use a proper prefix: rdt_group
> A proper description might be:
> rdt_group points to the rdt group to which the task belongs.
In the patch set, I use the name "rdtgroup" to represent a rdt group.
Should I change the name "rdtgroup" to "rdt_group" in all patches
Including descriptions and code?