Re: [PATCH 1/2] usb: typec: Add USB Power Delivery sink port support

From: Felipe Balbi
Date: Fri Jul 15 2016 - 06:31:35 EST



Hi,

Oliver Neukum <oneukum@xxxxxxxx> writes:
> On Fri, 2016-07-15 at 10:25 +0300, Felipe Balbi wrote:
>> > +int pd_sink_queue_msg(struct pd_sink_msg *msg)
>> > +{
>> > + unsigned long flags;
>> > + struct pd_sink_port *port;
>> > +
>> > + if (msg->port < 0 || msg->port >= MAX_NR_SINK_PORTS) {
>> > + pr_err("Invalid port number\n");
>> > + return -EINVAL;
>> > + }
>> > +
>> > + port = sink_ports[msg->port];
>> > +
>> > + spin_lock_irqsave(&port->rx_lock, flags);
>> > + list_add_tail(&msg->list, &port->rx_list);
>> > + spin_unlock_irqrestore(&port->rx_lock, flags);
>> > +
>> > + queue_work(port->rx_wq, &port->rx_work);
>>
>> can we really queue several messages at a time? It seems unfeasible to
>> me. It's not like we can queue several power request in a role. Why do
>> you need this workqueue? Why don't you process message here, in place?
>
> A reset can come at any time.

right, but that's not how this is being used. IMHO, rx_work is a
misnomer. If you look at how typec_wcove (patch 2 in this series) uses
it, you'll see that pd_sink_queue_msg() is called to queue a reply to a
message that was *already* received. We can't have two replies, right?

In any case, this is a minor problem.

--
balbi

Attachment: signature.asc
Description: PGP signature