Re: [PATCH v2 4/6] [media] vivid: code refactor for color representation

From: Hans Verkuil
Date: Fri Jul 15 2016 - 14:12:48 EST


On 07/15/2016 07:58 PM, Hans Verkuil wrote:
> On 07/15/2016 06:13 PM, Ricardo Ribalda Delgado wrote:
>> Replace is_yuv with color_representation. Which can be used by HSV
>> formats.
>>
>> This change should ease the review of the following patches.
>
> It's a bit of a mouthful. How about calling this color_enc and TPG_COLOR_ENC_?
> (i.e. color encoding).
>
> I would also like to have a TPG_COLOR_ENC_LUMA for the greyscale formats.
> This patch is a good opportunity to add that.

Also note that docs-next is older than the master branch w.r.t. the tpg.
You're missing two is_yuv checks is docs-next that are present in the master.

Also:

>> +static const char *tpg_color_representation_str(enum tgp_color_representation
>> + color_representation)
>> +{
>> + switch (color_representation) {
>> +

Drop empty line.

>> + case TGP_COLOR_REPRESENTATION_YUV:
>> + return "YCbCr";
>> + case TGP_COLOR_REPRESENTATION_RGB:
>> + default:
>> + return "RGB";
>> +
>> + }
>> +}

Regards,

Hans