[PATCH 1079/1285] Replace numeric parameter like 0444 with macro

From: Baole Ni
Date: Tue Aug 02 2016 - 10:26:29 EST


I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@xxxxxxxxx>
Signed-off-by: Baole Ni <baolex.ni@xxxxxxxxx>
---
lib/842/842_compress.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/lib/842/842_compress.c b/lib/842/842_compress.c
index 4051339..bf45ea3 100644
--- a/lib/842/842_compress.c
+++ b/lib/842/842_compress.c
@@ -42,7 +42,7 @@
* so that any length buffer can be compressed.
*/
static bool sw842_strict;
-module_param_named(strict, sw842_strict, bool, 0644);
+module_param_named(strict, sw842_strict, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);

static u8 comp_ops[OPS_MAX][5] = { /* params size in bits */
{ I8, N0, N0, N0, 0x19 }, /* 8 */
--
2.9.2