Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro

From: Jiri Slaby
Date: Tue Aug 02 2016 - 13:06:11 EST


On 08/02/2016, 03:57 PM, Alan Stern wrote:
>> --- a/drivers/cpufreq/powernow-k7.c
>> +++ b/drivers/cpufreq/powernow-k7.c
>> @@ -683,7 +683,7 @@ static void __exit powernow_exit(void)
>> cpufreq_unregister_driver(&powernow_driver);
>> }
>>
>> -module_param(acpi_force, int, 0444);
>> +module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH);
>
> This is an excellent example. To me, 0444 is _much_ more readable and
> understandable than S_IRUSR | S_IRGRP | S_IROTH.

If anything, that should be S_IRUGO. However, I personally prefer
numbers over macros too.

thanks,
--
js
suse labs