RE: [PATCH 0071/1285] Replace numeric parameter like 0444 with macro

From: David Laight
Date: Wed Aug 03 2016 - 11:49:58 EST


From: Baole Ni
> Sent: 02 August 2016 11:39
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
...
> -module_param(debug, ulong, 0644);
> +module_param(debug, ulong, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
...

If you're as old as I am the octal constant is easier to read!

David