Re: [PATCH] smc91x: remove ARM hack for unaligned 16-bit writes

From: Robert Jarzmik
Date: Sat Aug 27 2016 - 11:39:26 EST

Russell King - ARM Linux <linux@xxxxxxxxxxxxxxx> writes:

> On Thu, Aug 25, 2016 at 08:02:35PM +0200, Robert Jarzmik wrote:
>> Arnd Bergmann <arnd@xxxxxxxx> writes:
>> > On Thursday, August 25, 2016 4:43:04 PM CEST Arnd Bergmann wrote:
>> >> drivers/net/ethernet/smsc/smc91x.h | 50 +++++++++++++++++++++++---------------
>> >> 1 file changed, 30 insertions(+), 20 deletions(-)
>> >>
>> >> While this patch fixes one bug on Neponset, it probably doesn't address
>> >> the one that Russell ran into first, so this is for review only for now,
>> >> until the remaining problem(s) have been worked out.
>> >>
>> >
>> > The comment should have been on another patch, my mistake. please
>> > see v2.
>> >
>> > Arnd
>> Hi Arnd,
>> I didn't review the patch thoroughly, but I launched your 2 patches in my pxa
>> little farm.
>> The result is that lubbock and mainstone are all right, but zylonite is broken
>> (ie. networkless). I removed then these 2 patches and zylonite worked again.
>> I have also an error message on the console on a "broken" zylonite :
>> Changing smcs91x MAC address to 08:00:3e:26:0a:5b: ifconfig: SIOCSIFHWADDR:
>> Device or resource busy
>> I reran the test twice (2 times with your patches, 2 times without), the result
>> looks consistent, ie. zylonite doesn't really like them.
> Please try the patch below. I sent this to Will a few days ago, as
> he said (on irc) that he was also seeing problems on a platform he
> had, but I've yet to hear back. I've not posted it yet because I
> haven't got around to writing a commit description for it.
> It does require that at least one of 8-bit or 16-bit accesses are
> supported, but I think that's already true.

Hi Russell,

With your patch :
- lubbock, mainstone and zylonite boards are working correctly
=> ie. all my boards are working correctly

- the message "ifconfig: SIOCSIFHWADDR: Device or resource busy" is still there
=> this message is here even without your patch, so it's rather not relevant
=> this message is triggered by an "/sbin/ifconfig eth0 hw ether
08:00:3e:26:0a:5b" command

So from a PXA testing point of view it's all good, ie.
Tested-by: Robert Jarzmik <robert.jarzmik@xxxxxxx>