Re: [PATCH 1/5] IA64-IRQ: Use kmalloc_array() in sn_irq_lh_init()

From: Joe Perches
Date: Sun Aug 28 2016 - 14:33:15 EST

On Sun, 2016-08-28 at 11:28 +0200, Julia Lawall wrote:

> I do think that there is some value in doing similar things in a uniform
> way, using meaningful names, even if in a particular case it doesn't help
> performance or reduce code size.  Even duplicating code could be OK if it
> is not in a critical path and it makes the code overall easier to
> understand.  But if the maintainer prefers the code not to be duplicated,
> then of course it should not be duplicated.

All true too, thanks Julia.

It's all maintainer choice.