On 09/18/2016 09:11 PM, Davidlohr Bueso wrote:
Davidlohr Bueso (5):The only patch that I don't like.
ipc/sem: do not call wake_sem_queue_do() prematurely
Especially: patch 2 of the series removes the wake_up_q from the function epilogue.
So only the code duplication (additional instances of rcu_read_unlock()) remains, I don't see any advantages.
ipc/sem: rework task wakeupsAcked
ipc/sem: optimize perform_atomic_semop()I'm still thinking about it.
Code duplication is evil, but perhaps it is the best solution.
What I don't like is the hardcoded "< BITS_PER_LONG".
At least:
- (1 << sop->sem_num)
+ (1 << (sop->sem_num%BITS_PER_LONG))
ipc/sem: explicitly inline check_restartDo we really need that? Isn't that the compiler's task?
Especially since the compiler is already doing it correctly.
ipc/sem: use proper list api for pending_list wakeupsAcked