Re: GPU-DRM-TTM: Fine-tuning for several function implementations

From: Christian KÃnig
Date: Fri Sep 23 2016 - 07:17:18 EST

Am 23.09.2016 um 13:07 schrieb SF Markus Elfring:
It's just the names like "out" or "restart" perfectly explain why the labels exists.
I have got an other impression.

So they fulfill this requirement from the coding style as far as I can see.
Short identifiers might look more convenient in some cases because
they are quicker to type.

So why do you want to change them?
1. I suggest to select identifiers also for jump labels which are more meaningful
and eventually unique for some function implementations.

I completely disagree. A longer identifier is not necessarily more meaningful than a shorter one.

The difference between calling a label "retry" and "lock_retry" is negligible, doesn't improve readability as far as I can see and is actually incorrect because the main meaning of the label is that we don't take the lock but rather that we restart the allocation operation.

Calling the label "unlock" instead of "out" is arguable a little better, but nothing I would call a major improvement either.

So that is a clear NAK to all those patches.

2. How do you think about to add a single space character before any label?

Bad as well. Why would anybody want to do this?