Re: GPU-DRM-TTM: Fine-tuning for several function implementations

From: Christian KÃnig
Date: Fri Sep 23 2016 - 09:06:40 EST

Am 23.09.2016 um 13:49 schrieb SF Markus Elfring:
Calling the label "unlock" instead of "out" is arguable a little better,
Thanks that you can follow a renaming for this direction in principle.

but nothing I would call a major improvement either.
This was not my intention for such an use case.

I am proposing some small software updates according to such a design pattern.

So that is a clear NAK to all those patches.
Do you reject also update steps like the following then?

* drm/ttm: Use kmalloc_array() in two (or four?) functions"

* drm/ttm: Less function calls in ttm_dma_pool_init() after error detection

The reason behind the advise to use kmalloc_array() is to avoid overruns when one of the parameters come from an IOCTL and so are controllable by user space.

Those overruns where the source of numerous security problems, but in this case the parameters don't come from an IOCTL and aren't user space controllable.

So this change actually doesn't make to much sense either, but I'm leaning towards accepting them for coding style consistency.


* Would you like to improve the usage of the variables "n" and "t"
in the function "ttm_dma_pool_init" any further as Joe Perches suggested it?

2. How do you think about to add a single space character before any label?
Bad as well. Why would anybody want to do this?
Do you find another software evolution interesting according to a recent commit?

"docs: Remove space-before-label guidance from CodingStyle"