[PATCH 0/2] Define positive return value to RPM_SUSPEND for runtime-suspended devices

From: Chen Yu
Date: Tue Sep 27 2016 - 23:18:46 EST


This patch set is to define the positive value returned
by device .prepare() callbacks, which is used to indicate
the devices are OK to remain in runtime-suspended during
system sleep. A precise return value would make the code
more readable.

Based on this definition, optimized the suspend process
in intel-lpss driver.

Chen Yu (2):
PM / sleep: Return RPM_SUSPENDED to keep devices in runtime-suspended
mfd: intel-lpss: Avoid resuming runtime-suspended lpss unnecessarily

Documentation/power/devices.txt | 8 ++++----
Documentation/power/runtime_pm.txt | 2 +-
drivers/base/power/main.c | 8 ++++++--
drivers/mfd/intel-lpss.c | 9 +++++++++
4 files changed, 20 insertions(+), 7 deletions(-)

--
2.7.4