Re: md/dm-crypt: Rename a jump label in crypt_message() ?

From: SF Markus Elfring
Date: Fri Sep 30 2016 - 07:33:20 EST

> Again, I wrote the paragraph in CodingStyle.

This is obvious from the corresponding commit "add some more error
handling guidelines" (ea04036032edda6f771c1381d03832d2ed0f6c31
on 2014-12-02).

> I just said that it's a good idea to think about label names

I agree also to such a desire.

> instead of using GW-BASIC style numbered labels,

Is this kind of wording another weakness in the discussed document?
How many guidance do programmers get from such a software specification?

I came a few source code places along where I proposed corresponding changes.

> I didn't say

You did not say anything about some details as it is often easier to express
several aspects in vague and general terms.

> go around bothering everyone with waste of time cleanup patches.

I find it still debatable if the shown software development efforts
are really "wasted".

It seems that also the Linux development community is mixed about
related interpretations.

> I specifically did not say that "out:" or "error:" labels are bad names.

Did you inform me once that you had also a special opinion about an identifier
like "out"?

The C compiler will accept them as usual. But do we occasionally prefer
to express implementation details a bit better there?

> Those are common style in the kernel.

* Which impressions can you get from a statement like "goto fail;"
or "goto error;"?

* Do any exception handling implementations should be reconsidered
at such places?

> Please stop sending these patches.

Could it happen that the change acceptance will increase also for
the suggested renaming of jump labels if maintainers from other subsystems
would dare to respond once more in a positive way for such a software refactoring?