Re: [PATCH v2 2/4] ACPI / gpio: Add support for naming GPIOs
From: Andy Shevchenko
Date: Sun Oct 09 2016 - 13:08:37 EST
On Sun, Oct 9, 2016 at 6:01 PM, Mika Westerberg
> On Fri, Oct 07, 2016 at 08:05:14PM +0300, Andy Shevchenko wrote:
>> On Thu, Sep 29, 2016 at 4:39 PM, Mika Westerberg
>> <mika.westerberg@xxxxxxxxxxxxxxx> wrote:
>> > + if (!chip->names)
>> > + acpi_gpiochip_set_names(acpi_gpio);
>> > +
>> I'm okay with this, though wouldn't be better to call it
>> unconditionally like it's done for below call and move check inside?
> DT does it like this. I can move the check inside the function as well.
Up to you. If it even worth to change.
With Best Regards,