Re: [PATCH v8 2/3] Documentation: Add binding document for Lattice iCE40 FPGA manager

From: Joel Holdsworth
Date: Mon Nov 07 2016 - 14:00:24 EST

+ cdone-gpios = <&gpio 24 GPIO_ACTIVE_HIGH>;
+ reset-gpios = <&gpio 22 GPIO_ACTIVE_LOW>;

Wouldn't it make more sense to have "gpios" and "gpio-names" ? That
scales better imo, although in this case we cannot really talk about

I don't believe that would be conventional. '-gpios' seems to be the standard over '-gpio' even for a single GPIO.

Having multiple GPIOs in that field is only relevant when it could be an array e.g. multiple chip-select GPIO lines. Not for multiple GPIOs with differing functions.

Also it doesn't fit with the way devm_gpiod_get works where you select GPIO(s) from the device-tree, and specify whether it's an input or an output. In this case one is an output, one is an input.