Re: [PATCH 1/4] DW DMAC: rename is_private property as ordered by DT policy

From: Andy Shevchenko
Date: Wed Nov 16 2016 - 10:14:13 EST


On Wed, 2016-11-16 at 16:56 +0300, Eugeniy Paltsev wrote:
> Rename is_private to is-private as ordered by DT policy.
> The change leaves the support for the old format.
>
> Signed-off-by: Eugeniy Paltsev <Eugeniy.Paltsev@xxxxxxxxxxxx>
> ---
> Âdrivers/dma/dw/platform.c | 2 ++
> Â1 file changed, 2 insertions(+)
>
> diff --git a/drivers/dma/dw/platform.c b/drivers/dma/dw/platform.c
> index 5bda0eb..4103f1d 100644
> --- a/drivers/dma/dw/platform.c
> +++ b/drivers/dma/dw/platform.c
> @@ -128,6 +128,8 @@ dw_dma_parse_dt(struct platform_device *pdev)
> Â
> Â if (of_property_read_bool(np, "is_private"))
> Â pdata->is_private = true;
> + else if (of_property_read_bool(np, "is-private"))
> + pdata->is_private = true;

First, try new one, then fall back.

> Â
> Â if (!of_property_read_u32(np, "chan_allocation_order", &tmp))
> Â pdata->chan_allocation_order = (unsigned char)tmp;

--
Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
Intel Finland Oy