Re: [PATCH 1/4] statx: Add a system call to make enhanced file info available [ver #3]

From: Michael Kerrisk (man-pages)
Date: Thu Nov 24 2016 - 03:14:25 EST


Hi Andreas,

On 11/23/2016 11:57 PM, Andreas Dilger wrote:
> On Nov 23, 2016, at 1:37 AM, Michael Kerrisk <mtk.manpages@xxxxxxxxx> wrote:
>>

[...]

>>> ===============
>>> NEW SYSTEM CALL
>>> ===============
>>>
>>> The new system call is:
>>>
>>> int ret = statx(int dfd,
>>> const char *filename,
>>> unsigned int flags,
>>
>> In the 0/4 of this patch series, this argument is called 'atflags'.
>> These should be consistent. 'flags' seems correct to me.
>
> Given that there are a number of different flags and masks in use for
> this syscall, naming this field "atflags" makes it more clear what it
> is used for.

Well, yes, but in all of the "at" calls the argument is just flags.
So, better to be consistent in that dimension, I'd say, and then
make sure we perhaps have meaningfil names for the fiellds, as you suggest next:


>>> unsigned int mask,
>
> Similarly, naming this field "request_mask" would also be more clear,
> and matches what is used elsewhere in the code.
>
> That said, I don't care enough about this detail to request a patch refresh,
> but it would be useful for the man pages.


--
Michael Kerrisk
Linux man-pages maintainer; http://www.kernel.org/doc/man-pages/
Linux/UNIX System Programming Training: http://man7.org/training/