From: Johannes Weiner
Date: Wed Jan 25 2017 - 15:25:51 EST

On Wed, Jan 18, 2017 at 03:07:32AM -0800, Paul E. McKenney wrote:
> A group of Linux kernel hackers reported chasing a bug that resulted
> from their assumption that SLAB_DESTROY_BY_RCU provided an existence
> guarantee, that is, that no block from such a slab would be reallocated
> during an RCU read-side critical section. Of course, that is not the
> case. Instead, SLAB_DESTROY_BY_RCU only prevents freeing of an entire
> slab of blocks.
> However, there is a phrase for this, namely "type safety". This commit
> therefore renames SLAB_DESTROY_BY_RCU to SLAB_TYPESAFE_BY_RCU in order
> to avoid future instances of this sort of confusion.
> Signed-off-by: Paul E. McKenney <paulmck@xxxxxxxxxxxxxxxxxx>

This has come up in the past, and it always proved hard to agree on a
better name for it. But I like SLAB_TYPESAFE_BY_RCU the best out of
all proposals, and it's much more poignant than the current name.

Acked-by: Johannes Weiner <hannes@xxxxxxxxxxx>