[PATCH] x86/fpu: Unify the naming of the FPU register cache validity flags
From: Ingo Molnar
Date: Thu Jan 26 2017 - 10:05:34 EST
* Ingo Molnar <mingo@xxxxxxxxxx> wrote:
> What we could do is to unify the naming to explain all this a bit better - right
> now there's very little indication that ->fpregs_cached is closely related to
> For example we could rename them to:
> ->fpregs_cached => ->fpregs_owner [bool]
> fpu_fpregs_owner_ctx => fpregs_owner_ctx [ptr]
> Clearing ->fpregs_owner or setting fpregs_owner_ctx to NULL invalidates the
> cache and it's clear from the naming that the two values are closely related.
Something like the patch below - only minimally tested.