Re: [PATCH] tracing/kprobes: fix __init annotation

From: Masami Hiramatsu
Date: Sun Feb 05 2017 - 21:27:42 EST


On Wed, 1 Feb 2017 17:57:56 +0100
Arnd Bergmann <arnd@xxxxxxxx> wrote:

> clang complains about "__init" being attached to a struct name:
>
> kernel/trace/trace_kprobe.c:1375:15: error: '__section__' attribute only applies to functions and global variables
>
> The intention must have been to mark the function as __init instead of
> the type, so move the attribute there.
>
> Fixes: f18f97ac43d7 ("tracing/kprobes: Add a helper method to return number of probe hits")
> Signed-off-by: Arnd Bergmann <arnd@xxxxxxxx>

Looks good to me.

Acked-by: Masami Hiramatsu <mhiramat@xxxxxxxxxx>

Thanks!

> ---
> kernel/trace/trace_kprobe.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c
> index a133ecd741e4..7ad9e53ad174 100644
> --- a/kernel/trace/trace_kprobe.c
> +++ b/kernel/trace/trace_kprobe.c
> @@ -1372,7 +1372,7 @@ kprobe_trace_selftest_target(int a1, int a2, int a3, int a4, int a5, int a6)
> return a1 + a2 + a3 + a4 + a5 + a6;
> }
>
> -static struct __init trace_event_file *
> +static __init struct trace_event_file *
> find_trace_probe_file(struct trace_kprobe *tk, struct trace_array *tr)
> {
> struct trace_event_file *file;
> --
> 2.9.0
>


--
Masami Hiramatsu <mhiramat@xxxxxxxxxx>