Re: [RFC PATCH] mm: move pcp and lru-pcp drainging into vmstat_wq
From: Tetsuo Handa
Date: Wed Feb 08 2017 - 07:45:00 EST
Mel Gorman wrote:
> > > It also feels like vmstat is now a misleading name for something that
> > > handles vmstat, lru drains and per-cpu drains but that's cosmetic.
> > yeah a better name sounds like a good thing. mm_nonblock_wq?
> it's not always non-blocking. Maybe mm_percpu_wq to describev a workqueue
> that handles a variety of MM-related per-cpu updates?
Why not make it global like ones created by workqueue_init_early() ?