Re: [PATCH] scsi: cxgb3i: remove redundant null check and kfree on skb

From: Dan Carpenter
Date: Tue Mar 14 2017 - 05:09:01 EST


On Mon, Mar 13, 2017 at 07:14:08PM +0000, Colin King wrote:
> From: Colin Ian King <colin.king@xxxxxxxxxxxxx>
>
> On the error exit path, skb is always null, so the non-null check
> and __kfree_skb call are redundant. Remove the redundant code,
> rename the rel_release label to err and make error paths jump to
> the err exit path.
>
> Detected by CoverityScan, CID#114328 ("Logically Dead Code")
>
> Signed-off-by: Colin Ian King <colin.king@xxxxxxxxxxxxx>
> ---
> drivers/scsi/cxgbi/cxgb3i/cxgb3i.c | 10 ++++------
> 1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/scsi/cxgbi/cxgb3i/cxgb3i.c b/drivers/scsi/cxgbi/cxgb3i/cxgb3i.c
> index 1880eb6..f453a78 100644
> --- a/drivers/scsi/cxgbi/cxgb3i/cxgb3i.c
> +++ b/drivers/scsi/cxgbi/cxgb3i/cxgb3i.c
> @@ -972,21 +972,21 @@ static int init_act_open(struct cxgbi_sock *csk)
> &csk->daddr.sin_addr.s_addr);
> if (!csk->l2t) {
> pr_err("NO l2t available.\n");
> - return -EINVAL;
> + goto err;

err is a bad name because it doesn't say what the goto does. Imagine
if function names were so opaque. The most readable thing is a direct
return.

Also that's the least bug prone thing.

regards,
dan carpenter