Re: [PATCH v3 2/8] staging: rtl8192e: Fix coding style

From: Suniel Mahesh
Date: Wed Mar 15 2017 - 07:10:49 EST


On Wednesday 15 March 2017 03:44 PM, Dan Carpenter wrote:
On Wed, Mar 15, 2017 at 03:21:51PM +0530, sunil.m@xxxxxxxxxxxx wrote:
@@ -1796,7 +1796,7 @@ static short _rtl92e_alloc_rx_ring(struct net_device *dev)

for (rx_queue_idx = 0; rx_queue_idx < MAX_RX_QUEUE; rx_queue_idx++) {
priv->rx_ring[rx_queue_idx] = pci_zalloc_consistent(priv->pdev,
- sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount,
+ sizeof(*priv->rx_ring[rx_queue_idx]) * priv->rxringcount,
&priv->rx_ring_dma[rx_queue_idx]);

No, don't do that. The original was easier to read. Ignore
checkpatch.pl if it gives you bad advice.

if (!priv->rx_ring[rx_queue_idx] ||
(unsigned long)priv->rx_ring[rx_queue_idx] & 0xFF) {
@@ -2272,7 +2272,8 @@ static int _rtl92e_ioctl(struct net_device *dev, struct ifreq *rq, int cmd)
int ret = -1;
struct rtllib_device *ieee = priv->rtllib;
u32 key[4];
- const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff, 0xff};
+ const u8 broadcast_addr[ETH_ALEN] = {0xff, 0xff, 0xff, 0xff, 0xff,
+ 0xff};

Just drop this patch... The original is better.

regards,
dan carpenter

hi, when you say drop this patch, should I send the entire patch set as PATCH v4 with this particular patch dropped ?

regards
suniel