Re: [PATCH v2] netfilter: Clean up tests if NULL returned on failure

From: SIMRAN SINGHAL
Date: Wed Mar 29 2017 - 05:16:34 EST


On Wed, Mar 29, 2017 at 2:19 PM, SIMRAN SINGHAL
<singhalsimran0@xxxxxxxxx> wrote:
> On Wed, Mar 29, 2017 at 12:25 PM, Jan Engelhardt <jengelh@xxxxxxx> wrote:
>>
>> On Tuesday 2017-03-28 18:23, SIMRAN SINGHAL wrote:
>>>On Tue, Mar 28, 2017 at 7:24 PM, Jan Engelhardt <jengelh@xxxxxxx> wrote:
>>>> On Tuesday 2017-03-28 15:13, simran singhal wrote:
>>>>
>>>>>Some functions like kmalloc/kzalloc return NULL on failure. When NULL
>>>>>represents failure, !x is commonly used.
>>>>>
>>>>>@@ -910,7 +910,7 @@ ip_vs_new_dest(struct ip_vs_service *svc, struct ip_vs_dest_user_kern *udest,
>>>>> }
>>>>>
>>>>> dest = kzalloc(sizeof(struct ip_vs_dest), GFP_KERNEL);
>>>>>- if (dest == NULL)
>>>>>+ if (!dest)
>>>>> return -ENOMEM;
>>>>
>>>> This kind of transformation however is not cleanup anymore, it's really
>>>> bikeshedding and should be avoided. There are pro and cons for both
>>>> variants, and there is not really an overwhelming number of arguments
>>>> for either variant to justify the change.
>>>
>>>Sorry, but I didn't get what you are trying to convey. And particularly pros and
>>>cons of both variants.
>>
>> The ==NULL/!=NULL part sort of ensures that the left side is a pointer, which
>> is lost when just using the variable and have it implicitly convert to bool.
>
> Thanks for the explaination!!!!
>
> But, according to me we should prefer != NULL over ==NULL according to
> coding style.

Sorry their is typing mistake in above.

But, according to me we should prefer !var over ( var ==NULL ) according to the
coding style