Re: [PATCH] cgroup: switch to BUG_ON()

From: Zefan Li
Date: Wed Apr 05 2017 - 01:53:10 EST


On 2017/3/27 0:24, Nicholas Mc Guire wrote:
> Use BUG_ON() rather than an explicit if followed by BUG() for
> improved readability and also consistency.
>
> Signed-off-by: Nicholas Mc Guire <der.herr@xxxxxxx>
> ---
>
> Found by coccinelle: bugon.cocci
> ./kernel/cgroup/cpuset.c:2125:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
> ./kernel/cgroup/cpuset.c:2127:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
> ./kernel/cgroup/cpuset.c:2143:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG.
>
> BUG_ON() wraps the explicit if condition and is actually in use for
> all conditional BUG() cases in cpuset.c except in this one function.
>
> Patch was compile-tested with: x86_64_defconfig (implies CONFIG_CPUSETS=y)
> (checkpatch warnings for this patch seem to be false-positives - the
> BUG_ON should be fine)
>
> Patch is against 4.11-rc3 (localversion-next is next-20170324)
>

Acked-by: Zefan Li <lizefan@xxxxxxxxxx>