On 11/04/17 11:26, Oleksandr Andrushchenko wrote:Exactly, IMO this driver does need attention, but it
On 04/11/2017 11:50 AM, Juergen Gross wrote:Sure. After all I think I can merge the patches, as reading width and
Add a parameter for setting the resolution of xen-kbdfront in order toif you are about to release yet another version of the series,
be able to cope with a (virtual) frame buffer of arbitrary resolution.
Signed-off-by: Juergen Gross <jgross@xxxxxxxx>
---
drivers/input/misc/xen-kbdfront.c | 18 ++++++++++++++----
1 file changed, 14 insertions(+), 4 deletions(-)
diff --git a/drivers/input/misc/xen-kbdfront.c
b/drivers/input/misc/xen-kbdfront.c
index 3900875dec10..90e7981a7768 100644
--- a/drivers/input/misc/xen-kbdfront.c
+++ b/drivers/input/misc/xen-kbdfront.c
@@ -41,6 +41,12 @@ struct xenkbd_info {
char phys[32];
};
+enum { KPARAM_WIDTH, KPARAM_HEIGHT, KPARAM_CNT };
+static int size[KPARAM_CNT] = { XENFB_WIDTH, XENFB_HEIGHT };
could you please also rename "size" to "ptr_size/pointer_size/XXX",
so later when I add multi-touch support I can have
"mtouch_size" module parameter and they are consistent all together?
height a second time while connecting the device seems to be pointless.
While logically patch 2 seems to correct the connection process there
was never a problem with it being wrong: width and height would have
been already read during probing of the device so missing to read them
again wouldn't lead to any wrong settings.
Juergen