Re: [PATCH] tty: serdev: fix serdev_device_write return value

From: Andy Shevchenko
Date: Wed May 03 2017 - 13:44:29 EST


On Tue, May 2, 2017 at 12:25 PM, Johan Hovold <johan@xxxxxxxxxx> wrote:
> On Mon, May 01, 2017 at 07:17:14PM -0500, Rob Herring wrote:

>> - return ret < 0 ? ret : (count ? -ETIMEDOUT : 0);
>> + return ret < 0 ? ret : (count ? -ETIMEDOUT : wr_cnt);
>
> That's some nasty use of the ternary operator. Ditching it completely
> would be more readable.
>
> if (ret < 0)
> return ret;
>
> if (count)
> return -ETIMEDOUT;
>
> return wr_count;


While I agree on the first part, I would go still with one ternary at the end:

return count ? -ETIMEDOUT : wr_count;

--
With Best Regards,
Andy Shevchenko