Re: [RFC 09/10] x86/mm: Rework lazy TLB to track the actual loaded mm
From: Ingo Molnar
Date: Wed May 10 2017 - 01:57:35 EST
* Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:
> On Sun, 7 May 2017, Andy Lutomirski wrote:
> > /* context.lock is held for us, so we don't need any locking. */
> > static void flush_ldt(void *current_mm)
> > {
> > + struct mm_struct *mm = current_mm;
> > mm_context_t *pc;
> >
> > - if (current->active_mm != current_mm)
> > + if (this_cpu_read(cpu_tlbstate.loaded_mm) != current_mm)
>
> While functional correct, this really should compare against 'mm'.
>
> > return;
> >
> > - pc = ¤t->active_mm->context;
> > + pc = &mm->context;
So this appears to be the function:
static void flush_ldt(void *current_mm)
{
struct mm_struct *mm = current_mm;
mm_context_t *pc;
if (this_cpu_read(cpu_tlbstate.loaded_mm) != current_mm)
return;
pc = &mm->context;
set_ldt(pc->ldt->entries, pc->ldt->size);
}
why not rename 'current_mm' to 'mm' and remove the 'mm' local variable?
Thanks,
Ingo