Re: [PATCH v3 1/2] lib/btree.c: optimise the code by previously getpos function

From: Andy Shevchenko
Date: Thu May 18 2017 - 11:50:44 EST


On Thu, May 18, 2017 at 4:40 PM, Leno Hou <lenohou@xxxxxxxxx> wrote:
> Rework the getpos() helper function and use it to remove various
> open-coded implemetnations of its funtionality.

> for ( ; height > 1; height--) {
> - for (i = 0; i < geo->no_pairs; i++)
> - if (keycmp(geo, node, i, key) <= 0)
> - break;
> - if (i == geo->no_pairs)
> + i = getpos(geo, node, key);
> + if (i < 0)
> return -ENOENT;

Now it makes sense to

return i;

instead.

--
With Best Regards,
Andy Shevchenko