Re: [PATCH] staging: lustre: lnet: selftest: Change the type of variable to bool

From: Greg Kroah-Hartman
Date: Fri Jun 23 2017 - 16:25:49 EST

On Tue, Jun 20, 2017 at 02:36:37PM +0530, simran singhal wrote:
> This patch changes the type of variable done from int to boolean. As it
> is been used as a boolean in the function sfw_test_rpc_done(). It also
> makes the code more readable and bool data type also requires less
> memory in comparison to int data type.

Are you sure it takes less memory? What is the difference before and
after your patch? Don't make claims without having a way to back them
up :)


greg k-h