Hi,This clock name has changed in datasheet between STM32F4/STM32F7 and STM32H7, so, I'm not really happy too... But, as there is only one clock on F4/F7, its name is not important for the end user. Now that pclk appears, we need to distinguish the two clocks, and for the end user, it is better if the clock names match the datasheet.
This is mostly fine, even if I'm not too happy with the
s/ck_rtc/rtc_ck/.
On 26/06/2017 at 11:51:29 +0200, Amelie Delaunay wrote:OK, will be done in V2.
- rtc->ck_rtc = devm_clk_get(&pdev->dev, NULL);
- if (IS_ERR(rtc->ck_rtc)) {
- dev_err(&pdev->dev, "no ck_rtc clock");
- return PTR_ERR(rtc->ck_rtc);
+ match = of_match_device(stm32_rtc_of_match, &pdev->dev);
+ if (match && match->data)
+ rtc->data = (struct stm32_rtc_data *)match->data;
+ else
+ return -EINVAL;
This will never happen, you can remove that test.